MLMenu Plugin Beta

Plugins related to support of the MainLobby user interface.
90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Thu May 08, 2008 9:35 am

No you should still be able to use the button to navigate or run any commands. I use the option setting to turn on internet radio stations and then change color to show which one is one.

djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

Postby djsl » Sat May 10, 2008 11:50 pm

I am trying to get the track state working.

I would like to tint say button 3 in menu 1

the wiki shows this command:

SET_BUTTON_STATE~ButtonID~ButtonState(True/False)~MenuID

how should this look? here is what I tried with no results

MLServeCmd.MLMenu|SET_BUTTON_STATE~button_3~True~menu_1

I see that the wiki says that the state tint can be green or red, has that been changed to where I can specify the color in the plugin?

djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

Postby djsl » Tue May 13, 2008 8:24 pm

djsl wrote:
MLServeCmd.MLMenu|SET_BUTTON_STATE~button_3~True~menu_1



Tracy what is wrong with this command for changing state color of a button.

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Tue May 13, 2008 9:25 pm

I think you want to use the following:

MLMenu|Set_Button_State~3~True~1

unless you have the alias for the button set as Button_3 and the menu alias as Menu_1

You can also try toggle_state~3~1.

Tracy

djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

Postby djsl » Tue May 13, 2008 10:08 pm

I am getting an error when I try to change the state

here is the error:

5/13/2008 10:05:44 PM - Warning 13(Type mismatch) @ Line 770 in procedure doCmd of frmMain

here is what I am using from a macro command:

MLServeCmd.MLMenu|Set_Button_State~3~True~1


My alias is Menu1 and the button is 3

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Tue May 13, 2008 10:28 pm

I found the issue. The next version should take of it.

Tracy

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Mon Sep 01, 2008 6:31 pm

MLMenu updated.

Make SURE you backup your database before upgrading.
On initial launch the plugin will do some modifications on the existing database. The installer was modified to make database updates optional.

geodementia
New Member
New Member
Posts: 41
Joined: Wed Jan 23, 2008 4:06 am
Location: Sydney, Australia
Contact:

Postby geodementia » Wed Jan 14, 2009 10:54 pm

I'm trying to import the MLMenu xml file that I got from djsl (Thanks Jim), but every time I try to import it MLMenu Freezes. In fact the whole MLServer freezes, as it is so busy in an error loop that it needs to be restarted.

What I see in the logs when I try to import is:

1/15/2009 2:50:21 PM MLMenu Warning Server 1/15/2009 2:50:21 PM - Warning -2147217865(The Microsoft Jet database engine cannot find the input table or query 'ImportTable'. Make sure it exists and that its name is spelled correctly.) @ Line 80 in procedure DeleteRecords of SharedCode
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning 3265(Item cannot be found in the collection corresponding to the requested name or ordinal.) @ Line 40 in procedure ChangeSeed of ModDatabase
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning 91(Object variable or With block variable not set) @ Line 50 in procedure ChangeSeed of ModDatabase
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning 3265(Item cannot be found in the collection corresponding to the requested name or ordinal.) @ Line 60 in procedure ChangeSeed of ModDatabase
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning 91(Object variable or With block variable not set) @ Line 70 in procedure ChangeSeed of ModDatabase
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning -2147217900(Invalid SQL statement; expected 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT', or 'UPDATE'.) @ Line 230 in procedure cmdImport_Click of frmMain
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning 3704(Operation is not allowed when the object is closed.) @ Line 260 in procedure cmdImport_Click of frmMain
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning -2147217900(Invalid SQL statement; expected 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT', or 'UPDATE'.) @ Line 270 in procedure cmdImport_Click of frmMain
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning -2147217900(Invalid SQL statement; expected 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT', or 'UPDATE'.) @ Line 290 in procedure cmdImport_Click of frmMain
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning -2147217900(Invalid SQL statement; expected 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT', or 'UPDATE'.) @ Line 290 in procedure cmdImport_Click of frmMain
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning -2147217900(Invalid SQL statement; expected 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT', or 'UPDATE'.) @ Line 290 in procedure cmdImport_Click of frmMain
1/15/2009 2:50:22 PM MLMenu Warning Server 1/15/2009 2:50:22 PM - Warning -2147217900(Invalid SQL statement; expected 'DELETE', 'INSERT', 'PROCEDURE', 'SELECT', or 'UPDATE'.) @ Line 290 in procedure cmdImport_Click of frmMain


With the last line repeating infinitely multiple times per second.

I have uninstalled MLMenu (Removed the mdb and dll) and re-installed and get exactly the same result.

Any ideas ???

MLMenu version is 3.0.340
MLS is 3.0.557
Geoff
Sydney, Australia

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Thu Jan 15, 2009 2:01 pm

Send me the xml file you are trying to import. There's probably a coding error in the import or export routines.

geodementia
New Member
New Member
Posts: 41
Joined: Wed Jan 23, 2008 4:06 am
Location: Sydney, Australia
Contact:

Postby geodementia » Thu Jan 15, 2009 8:47 pm

pm sent....

djsl has given the XML to several others and they haven't had any issues....

I got the actual .mbd file and stuck that in and it's working - but then I tried to EXPORT what I had and got a whole swag of SQL errors again.

I'm running on win2k3 - I know there were some "hacks" that needed to be done for other plugins (DVDLobby from memory) - could there be something like this needed for MLMenu ???
Geoff

Sydney, Australia

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Thu Jan 15, 2009 9:04 pm

Windows 2K3. Install Microsoft's XML Version 6 server pak 2 from

http://www.microsoft.com/downloads/deta ... laylang=en

then see what happens.

geodementia
New Member
New Member
Posts: 41
Joined: Wed Jan 23, 2008 4:06 am
Location: Sydney, Australia
Contact:

Postby geodementia » Fri Jan 16, 2009 8:49 pm

Thanks Dave - that was the problem! After installing the XML pack and restarting MLS the Import and Export from MLMenu now work perfectly.

Perhaps this "trick" could be added to the Wiki for other 2k3 users.

Thanks again!
Geoff

Sydney, Australia


Return to “User Interface Support”

Who is online

Users browsing this forum: No registered users and 1 guest