MLPhonebook not updating (error messages in log)

Thread to discuss the MLOutlook family of applications: MLCalendar / MLEmail / MLPhoneBook
ghadlock
Senior Member
Senior Member
Posts: 118
Joined: Tue Feb 26, 2008 9:04 pm
Contact:

MLPhonebook not updating (error messages in log)

Postby ghadlock » Tue Apr 07, 2009 3:41 pm

Hello all. I just purchased / installed MLPhonebook and I can't manage to get it to update my contacts. Here are the versions I'm using:

MLServer 3.0.588 (installed at: C:\Program Files (x86)\MLServer)
MLPhonebook for ML Server: 3.0.404
MLOutlook Plugin 3.0.95
Microsoft Outlook 2007 SP1

I have 21 contacts (pretty clean content) and deleted all but one contact during testing, and still could not get the contacts to upload to the server and show up in MLPhonebook plug-in. Here's the log that I see in MLPhonebook on the server:


ML Phonebook Log (from server)
XML Import Succeeded
Number of Nodes - 21
deleted records
Error Path not found - (76) @line 660 in procedure ProcessXML of SharedCode
Server requested Client Update - (4/7/2009 2:15:02 PM)
Server requested Client Update - (4/7/2009 2:15:02 PM)
XML Import Succeeded
Number of Nodes - 1
deleted records
Error Path not found - (76) @line 660 in procedure ProcessXML of SharedCode
Server requested Client Update - (4/7/2009 2:25:22 PM)
Server requested Client Update - (4/7/2009 2:25:22 PM)
XML Import Succeeded
Number of Nodes - 21
deleted records
Error Path not found - (76) @line 660 in procedure ProcessXML of SharedCode
Server requested Client Update - (4/7/2009 2:30:37 PM)
Server requested Client Update - (4/7/2009 2:30:37 PM)
XML Import Succeeded
Number of Nodes - 21
deleted records
Error Path not found - (76) @line 660 in procedure ProcessXML of SharedCode
Server requested Client Update - (4/7/2009 2:31:03 PM)
Server requested Client Update - (4/7/2009 2:31:03 PM)

Here's the MLOutlook log from the same period:

Calendar update Completed @ 4/7/2009 2:29:50 PM
Calendar update Completed @ 4/7/2009 2:29:59 PM
Calendar update Completed @ 4/7/2009 2:30:56 PM
Error 10035 - (Socket is non-blocking and the specified operation will block)@line 1200 in procedure CopyContactsToXml of SharedCode

Any suggestions as to next steps in troubleshooting? Any way that I can see the path that is not being found? I suspect it might be the install location of MLServer but wanted to confirm.

Thanks in advance for the help!
Last edited by ghadlock on Tue Apr 07, 2009 4:34 pm, edited 4 times in total.

ghadlock
Senior Member
Senior Member
Posts: 118
Joined: Tue Feb 26, 2008 9:04 pm
Contact:

Postby ghadlock » Tue Apr 07, 2009 4:08 pm

Oh, the one comment that I do need to make. I'm running MLServer on Windows Server 2003 x64, so the path to the MLServer install is:

C:\Program Files (x86)\MLServer

That's caused a few things to break before, thought it might be the issue here as well. Just wanted to point that out especially since there is a path error involved.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Tue Apr 07, 2009 11:12 pm

The error you are seeing is a result of the plugin not finding the noimage.jpg file in the MLServer\Images\CallerID folder. Can you verify if it is there?

ghadlock
Senior Member
Senior Member
Posts: 118
Joined: Tue Feb 26, 2008 9:04 pm
Contact:

Postby ghadlock » Wed Apr 08, 2009 7:57 am

It wasn't there, so I copied & renamed unavailable.jpg and now everything is working great. Thanks Dave!


Return to “MLOutlook”

Who is online

Users browsing this forum: No registered users and 1 guest