MlCalendar and new events

Thread to discuss the MLOutlook family of applications: MLCalendar / MLEmail / MLPhoneBook
djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

MlCalendar and new events

Postby djsl » Tue Nov 06, 2007 3:11 pm

I have been playing with Mlcalendar but cannot get the create new event to save using the scene provided. Is this feauture working right.


Mlserver 3.0.357
Mlcalendar 3.0.204
Mllobby 3.00.95

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Tue Nov 06, 2007 3:37 pm

It was working...haven't been testing it for a while.

djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

Postby djsl » Tue Nov 06, 2007 11:05 pm

Ok, I just tried it again and no go on the new event creation, with the scene provided.

Here is the mlcalendar log:

Error Type mismatch - (13) @line 90 in procedure SaveRegistry of SharedCode
Error Type mismatch - (13) @line 90 in procedure SaveRegistry of SharedCode


here is the mlserver log:

11/6/2007 10:00:08 PM CmdReq kitchen MLServeCmd.MLCalendar|add_event~{{mlcalendar_select_by_calendar_label}}~{{mlcalendar_newevent_starttime}}~{{mlcalendar_newevent_endtime}}~{{mlcalendar_newevent_eventname}}~{{mlcalendar_newevent_alldayflag}}~{{mlcalendar_newevent_location}}~{{mlcalendar_ne
11/6/2007 10:00:08 PM Processing (1) kitchen MLServeCmd.MLCalendar|add_event~{{mlcalendar_select_by_calendar_label}}~{{mlcalendar_newevent_starttime}}~{{mlcalendar_newevent_endtime}}~{{mlcalendar_newevent_eventname}}~{{mlcalendar_newevent_alldayflag}}~{{mlcalendar_newevent_location}}~{{mlcalendar_ne
11/6/2007 10:00:08 PM Subst In kitchen add_event~{{mlcalendar_select_by_calendar_label}}~{{mlcalendar_newevent_starttime}}~{{mlcalendar_newevent_endtime}}~{{mlcalendar_newevent_eventname}}~{{mlcalendar_newevent_alldayflag}}~{{mlcalendar_newevent_location}}~{{mlcalendar_newevent_message}}
11/6/2007 10:00:08 PM Subst Out kitchen add_event~All~1:10 AM 11/26/2007~1:10 AM 11/26/2007~ALL~True~ALL~new
11/6/2007 10:00:09 PM CmdReq kitchen MLCmd|MLCommand~{{clientname}}~setProperty|layer~move~1024~30
11/6/2007 10:00:09 PM Processing (1) kitchen MLCmd|MLCommand~{{clientname}}~setProperty|layer~move~1024~30
11/6/2007 10:00:09 PM Subst In kitchen MLCommand~{{clientname}}~setProperty|layer~move~1024~30
11/6/2007 10:00:09 PM Subst Out kitchen MLCommand~kitchen~setProperty|layer~move~1024~30
11/6/2007 10:00:09 PM MLCMD kitchen MLCommand [setProperty|layer~move~1024~30]

djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

Postby djsl » Sun Nov 11, 2007 7:07 pm

Is this an issue or is it on my end?

Is anyone using the create new event?

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Sun Nov 11, 2007 8:27 pm

Can you enable the event log on the Outlook machines and see what you get in the event log? Hopefully we can see if it is getting that far.

djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

Postby djsl » Sun Nov 11, 2007 11:45 pm

here is the log from the outlook computer.


Event directed to another calendar
Complete XML processing
Calendar Updated - (11/11/2007 10:40:38 PM)
Next update scheduled for 21 hours
Outlook Calendar Exported to database - (11/11/2007 10:40:38 PM)
Server IP - 192.168.1.201
Client IP - 192.168.1.200
Calendar update Completed @ 11/11/2007 10:40:43 PM

Funboy
Intermediate
Intermediate
Posts: 294
Joined: Sat Mar 01, 2003 9:54 pm
Contact:

Postby Funboy » Sat Apr 12, 2008 7:59 pm

I'm having the same issue. When I try and create an event, immediately after the "add_event~...." in my log file, I see an error message from MLCalendar:

add_event~All~11:05 PM 4/27/2008~12:05 PM 4/27/2008~test~~home~doit
4/12/2008 6:55:32 PM - Error 13(Type mismatch) @ Line 90 in procedure SaveRegistry of SharedCode
4/12/2008 6:55:34 PM - Error 91(Object variable or With block variable not set) @ Line 230 in procedure ProcessXML of SharedCode

I'm seeing the first error when I do most anything with MLCalendar - but it seems to function fine even with the error message. However I cannot create events at all.
- Funboy

djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

Postby djsl » Wed May 21, 2008 9:13 am

ok I thought I give this a try again but I am still getting the same results, there is no event added and I get the following error in the log:


CMD: GET_DATE_INFO~29 FROM: kitchen
Cleared Variables due to not finding any events
Cleared Variables due to not finding any events
5/21/2008 9:09:36 AM - Error 13(Type mismatch) @ Line 90 in procedure SaveRegistry of SharedCode
CMD: add_event~~~~new~True~~newna FROM: kitchen
Event Added 5/21/2008 9:09:45 AM
5/21/2008 9:09:45 AM - Error 13(Type mismatch) @ Line 90 in procedure SaveRegistry of SharedCode


I am running all the latest ver
calendar 3.0.243
mlserver 3.0.508

djsl
Senior Member
Senior Member
Posts: 236
Joined: Thu Jun 08, 2006 12:56 am
Location: Chicago
Contact:

Postby djsl » Fri May 23, 2008 11:20 am

Has anyone got the add new event to work on this plugin?

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Fri May 23, 2008 2:02 pm

DJSL:

The problem appears to be your command:

Code: Select all

add_event~~~~new~True~~newna FROM: kitchen


The appropriate variables are not making it to the plugin. Once you get that part fixed I think you will be in business. Try sending the command from MLS and see what you get.

Comamnd -

Code: Select all

Add_event~Client~StartDate~EndDate~Event~AllDay(true or false)~Location~MemoField

User avatar
jjjukebox
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1024
Joined: Sat May 22, 2004 9:54 pm
Location: Toronto
Contact:

Postby jjjukebox » Wed May 28, 2008 7:48 am

I have the add event working but with 2 problems:

1) It puts it in my Outlook Calendar twice, same date, same time
2) Tends to hang up my Outlook program for about upto 3 minutes or so

Here is my log output:
CMD: add_event~Jim~11:15 AM 6/1/2008~11:45 AM 6/1/2008~Test 9~False~Test 9 Location~Test 9 Notes FROM: Workstation
Event Added 5/28/2008 8:43:23 AM
Timer fired

Any ideas?
J.J. Jukebox
Member

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Wed May 28, 2008 9:27 pm

JJ:
I copied your command into MLServer machine and it ran fine with no hangs in Outlook. It only created one event on my end. Did you do it from send commands in MLS or thru a button on ML?

Thanks
Tracy

User avatar
jjjukebox
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1024
Joined: Sat May 22, 2004 9:54 pm
Location: Toronto
Contact:

Postby jjjukebox » Wed May 28, 2008 10:37 pm

Tracy,

I use an ML Button with:
MLCalendar|add_event~{{mlcalendar_select_by_calendar_label}}~{{mlcalendar_newevent_starttime}}~{{mlcalendar_newevent_endtime}}~{{mlcalendar_newevent_eventname}}~{{mlcalendar_newevent_alldayflag}}~{{mlcalendar_newevent_location}}~{{mlcalendar_newevent_message}}

With further investigation I found that some errors came up in the attached MLCalendar Log that may be causing the hang.

It seems that an "add event" does some kind of automatic update request and since I have the MLOutlook Addin Export Criteria set for 6 Months Past & 6 Months Future this may take some time? Yes/No?

Also, from the log attached there is errors from event called "Don't Forget To Put Out All Types Of Garbage." and one called "Father's Day". Both have a " ' " in them (Don't & Father's) and seem to be translated as "'". Is that a problem?

I updated to MLOutLookAddin .84 and still get the double entry in the Outlook Calendar.

MLS 3.0.513
MLCalendar 3.0.243
MLOutlook Addin 3.0.84
OutLook 2003

Hope this helps
Thanx
You do not have the required permissions to view the files attached to this post.
J.J. Jukebox

Member

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Thu May 29, 2008 12:56 am

The next version should fix the issue with the '. You will need to update both the Outlook client and the plugin.

Whenever you add an event, it updates the calendar variables so that it can show the new event.

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Thu May 29, 2008 8:22 am

Outlook Addin and MLCalendar plugin updated in MLInstaller.


Return to “MLOutlook”

Who is online

Users browsing this forum: No registered users and 1 guest