Error on Startup of MLServer

Digital Media Recognition for music and movie meta data and cover art.
T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

Error on Startup of MLServer

Postby T.Wells » Sat Jul 11, 2009 9:16 pm

Hello,

I am getting an odd error when starting MLServer. MLServer does load but I keep getting MLWorker_Agent.mod errors on my screen about every 60 seconds. Here is the error message:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.FileLoadException: Could not load file or assembly 'AMG.Lasso, Version=3.7.30203.38, Culture=neutral, PublicKeyToken=30924397fd5f61c6' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
File name: 'AMG.Lasso, Version=3.7.30203.38, Culture=neutral, PublicKeyToken=30924397fd5f61c6'
at MLWorker_Agent.frmMain.Form_Load(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].



************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
MLWorker_Agent
Assembly Version: 3.75.3479.26679
Win32 Version: 3.75.3479.26679
CodeBase: file:///C:/Program%20Files/MLServer/MLWorker_Agent.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4016 (NetFxQFE.050727-4000)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Dart.PowerTCP.Sockets
Assembly Version: 1.1.1.0
Win32 Version: 1.1.1.0
CodeBase: file:///C:/Program%20Files/MLServer/Dart.PowerTCP.Sockets.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Sat Jul 11, 2009 9:48 pm

You're missing the Microsoft C++ Runtime files. I'll have to add them into the installer as an option.

Look in MLInstaller (Cinemar Installation Assistant) and do a search for C++. You'll see the installer for the run time file. Shut down MLServer and install the C++ files. Restart MLServer and see if the error messages are gone.

T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

Postby T.Wells » Sun Jul 12, 2009 7:15 am

CinemarDave wrote:You're missing the Microsoft C++ Runtime files. I'll have to add them into the installer as an option.

Look in MLInstaller (Cinemar Installation Assistant) and do a search for C++. You'll see the installer for the run time file. Shut down MLServer and install the C++ files. Restart MLServer and see if the error messages are gone.


Dave,
The the C++ files are included on the installer. I selected them when I installed.

I just re-installed the files (from MLinstaller) and I still get the errror.

Thanks.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Sun Jul 12, 2009 11:23 am

Do you have .NET 2.0 installed and Service Packed?

T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

Postby T.Wells » Sun Jul 12, 2009 12:04 pm

CinemarDave wrote:Do you have .NET 2.0 installed and Service Packed?


I am running .NET 3.5 framework with the latest service pack (i.e. no additional updates in Windows Update) on Vista x32 Ultimate with SP2 installed.

I see that .NET 2.0 was installed back in 2007.

.NET 3.5 Service Pack 1 was installed a few weeks back.

-T.Wells

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Sun Jul 12, 2009 12:09 pm

Then it is time for you to set up LogMeIn and let me see what is going on.

T.Wells
Intermediate
Intermediate
Posts: 379
Joined: Sat Sep 30, 2006 8:19 pm
Location: Philadelphia Suburbs
Contact:

Postby T.Wells » Tue Jul 14, 2009 8:04 am

CinemarDave wrote:Then it is time for you to set up LogMeIn and let me see what is going on.


Dave,

I think I have this sorted out now. I made some changes on Sunday night and I have not seen the error again.

I think the problem arose when I installed the C++ 2005 pack in the installer. I went to the MS site and downloaded and installed the 2008 C++ update an the error is now gone from my machine.

Thanks,
T.Wells


Return to “MLDMR”

Who is online

Users browsing this forum: No registered users and 1 guest