MLIPod Update

Forum to discuss iPod related plugins such as the Sonance iPort.
User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

MLIPod Update

Postby CinemarDave » Mon Sep 21, 2009 12:45 pm

A totally re-written MLIPod plugin is available for download via MLInstaller. All iPort users should download and test this version. You will need to download and install the Family Manager (v 3.75.19) and the iPort plugin (v 3.75.38) and also the Client Installer (v 3.75.19) because the demo 0019 scenes have been modified. You should also make sure that you download and install the latest version of MLServer (v 3.75.68) since it includes and updated MLWorker_Agent that makes refreshing the now-playing iPort cover art happen in a more timely fashion.

Please note that a new licensing scheme is in place for this plugin. You will need a new license key and activation code. Just send me an email if you need the new license key.

Post your test results here.

User avatar
ronsatter
Is there life beyond Cinemar?
Is there life beyond Cinemar?
Posts: 1304
Joined: Mon Dec 04, 2006 1:40 am
Location: San Leandro, CA
Contact:

Re: MLIPod Update

Postby ronsatter » Mon Sep 21, 2009 11:42 pm

Hi DaveP,

Just wanted to give out a "High Five" for all your hard work on rewriting these old "clunker" plugins. =D>

I think I speak for all the veteran ML users when I say "We appreciate your efforts to attend to our endless requests and resolve our ML issues as quickly as possible."

It's very difficult work ... if I were you, I'd be singing that old country tune Take This Job And Shove It!

Ron
If it ain't broke ... don't fix it!

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: MLIPod Update

Postby rileydog » Sun Sep 27, 2009 9:09 pm

Kudo's - this plugin is working very very well so far. Thanks a ton!

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Re: MLIPod Update

Postby mcascio » Mon Sep 28, 2009 9:15 am

This is great to hear. I know a lot of people think there has been a slow down on development or we have been ignoring the forum. But make no mistake, we are not vacationing in the Bahamas...we've been spending alot of time going back in to older plugins that were developed by third parties and repairing them so we can give them the official Cinemar seal-of-approval.
Mario Cascio
Cinemar, Inc.
http://www.cinemaronline.com

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: MLIPod Update

Postby rileydog » Tue Oct 06, 2009 3:41 pm

I am now 99% sure it is MLiPod that is crashing ML Server - I posted this issue on the new DirecTV plugin announcement, but I can crash ML Server when using the iPort interface pretty much every time.

About 10 or so songs into a playlist, ML Server will crash - I don't need to click anything to get it to crash, just start a playlist and several songs in, blam.

I upgraded to 3.75.42 -- I didn't notice any crashes like this prior to .42, I didn't keep copies of .40 or .41 to try those because it didn't crash like this when I beta testing...

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Re: MLIPod Update

Postby DavidL » Tue Oct 06, 2009 9:16 pm

I was seeing a crash with the latest MLDirecTV plugin. Nothing in the log, just MLServer got unresponsive. MLiPod may do same, but I haven't done much with that to tell. I see MLDirecTV version is regressed in MLInstaller, possibly due to yours and my observation that it was crashing mlserver.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLIPod Update

Postby CinemarDave » Sat Oct 10, 2009 2:20 pm

An updated version of the iPod Family and iPort driver has been released. You'll need to install both components. This version should eliminate the timeouts people have reported. Version 3.75.21 of the Family plugin and version 3.75.44 of the iPort driver is what you want to install.

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: MLIPod Update

Postby rileydog » Wed Oct 14, 2009 7:10 pm

Unbelievable - my FS4 is deader than a door nail. I cannot get it to power anymore. Don't know how it happened - dead.

Does the plugin work with the "newer" FS-22? It is 1/2 the price of the FS4 (no longer made) and claims to have RS232 control.

Just when I was finally using it... Eeek.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLIPod Update

Postby CinemarDave » Wed Oct 14, 2009 7:58 pm

All the iPort docks share the same protocol so you can use any one. It's not really that important that you choose the correct model from the drop down in the plugin because the protocol is the same.

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: MLIPod Update

Postby rileydog » Sun Oct 25, 2009 7:12 pm

Snagged a FS-5 on ebay - got it hooked up and it is working great. However...

I am getting a few crashes per day - I now know it is the iPod plugin because I have had it off for a few weeks and no crashes - now, I am using it and if I leave the iPod running (repeat on, so the playlist repeats), I will eventually get a crash.

No message, server restarts. Nothing in he log.

Any help will be appreciated - but, I got to say, this is a GREAT plugin!

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: MLIPod Update

Postby rileydog » Mon Oct 26, 2009 9:20 am

I can actually get it to crash often when playing music - today, it crashed in the second song - then, after 4 songs. I know it is this plugin because the crashes occur when the iPort is playing - if I do not play any music, it doesn't crash - if I disable the plugin, it doesn't crash - so there must be something going on specifically when music is playing.

Is there anything I can do to help troubleshoot? Any debugging I can turn on? Thanks.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLIPod Update

Postby CinemarDave » Mon Oct 26, 2009 12:21 pm

I'll probably have to spend some time on your system to look at it closely. I've been running the plugin here with a 6000 song playlist playing in random mode constantly for two weeks without a single error. Because the iPort is generating so many serial interrupts while a song is playing there is probably another plugin that does not like getting interrupted and that is what is causing the issue.

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: MLIPod Update

Postby rileydog » Mon Oct 26, 2009 6:46 pm

I am pretty certain you are correct - I think it is the DirectTV plugin because I updated the iPod & DirectTV plugins at the same time and noticed the crashes. Prior to the directv update, I didn't notice the crashes. I disabled all non-essential plugins. It would be great to get this resolved - when it works, it is absolutely a great setup! This ipod plugin when working is a dream.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLIPod Update

Postby CinemarDave » Mon Oct 26, 2009 6:49 pm

Can you try running without the DirecTV plugin for a while. I do not have DirecTV so it would be good to get it out of the loop.

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Re: MLIPod Update

Postby rileydog » Mon Oct 26, 2009 8:43 pm

I will give it a try tomorrow and let you know - it is one of the most used plugins but I will have the family watch movies tomorrow and turn it off - I will let you know tomorrow.

Thanks!


Return to “iPod”

Who is online

Users browsing this forum: No registered users and 1 guest