Dock/Redock issues

Forum to discuss iPod related plugins such as the Sonance iPort.
rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Dock/Redock issues

Postby rileydog » Fri Apr 27, 2007 1:09 pm

I updated to the latest and the jump to letter is working great!

I still am having strange behavior issues with docking/undocking.

I plugged my iPod into the dock - I had to click disconnect/connect from ML Server then it worked.

Then, I went to purchase a song and switched the dock to synch with iTunes (held down the note button on the iPort so it was Red). Synched then held the button down so it was white. iPort worked but none of the time variables or now playing variables are updating - but, the interface is working - I can select songs to play and it is fine. New song showed OK. The only way I could get the variables to work this time was to restart ML Server. Connect/Disconnect didn't do it. Using server 259 and plugin 126.

If I don't mess around with docking/undocking, it works flawless!

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Postby mcascio » Mon Apr 30, 2007 11:47 am

rileydog,

Please redownload the iPort Driver to see if it resolves your problem.
Mario Cascio
Cinemar, Inc.
http://www.cinemaronline.com

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Postby rileydog » Sat May 05, 2007 8:37 pm

I reinstalled and so far so good - it is working much better now. I do not see the issues in the post. Thanks!

User avatar
mcascio
Founder
Founder
Posts: 8270
Joined: Tue Jan 28, 2003 4:03 pm
Location: Kenosha, Wi
Contact:

Postby mcascio » Mon May 07, 2007 9:40 am

rileydog,

That's great to hear.
Mario Cascio

Cinemar, Inc.

http://www.cinemaronline.com

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Postby rileydog » Mon May 07, 2007 9:55 am

One thing to note is that I still have some weird behavior. I think I have it narrowed down to 2 issues:

When I quit ML Server, I get errors from iPort:

Run-time error -2147418105 (80010007): Automation error - The callee (server [not server application]) is not available (of note I get this same error now too for the MLHS Plugin - I have 2 error messages when I quit ML Server). I don't have any plugin windows open when I quit.

Second is that when I restart ML Server, it seems I have to go to the plugin interface to start making the ML scene work - I go to the plugin on ML Server, click on disconnect then connect - then, everything works.

I feel like I am getting really close - it is a great solution.

Thanks,

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Mon May 07, 2007 10:33 am

rileydog,
I have the same error message. It is the iport controller and very likely not MLHSPlugin. I believe that the iPort driver isn't gracefully shutting down which is causing other services to drop that things like MLELKM1, and MLHSPlugin require for their graceful shutdown.

Mario has not been able to duplicate so you and I are the only one's that are seeing this issue. The only problem is that it pops up a windows error message that can't be automatically cancelled (requires user interaction) so prevents an automatic MLServer restart.

Hopefully Mario will realize I am not the only crazy one so he can research further.

Thanx for the updates.

User avatar
jinksjj
Member
Member
Posts: 74
Joined: Mon Jan 23, 2006 12:04 pm
Contact:

Postby jinksjj » Thu Jul 26, 2007 2:10 pm

We have posted a new version of the IPort controller.

The new version will keep the docked state better in synch.

Also we would like to know if the error on MLServer shutdown goes away.

rileydog
Expert
Expert
Posts: 667
Joined: Wed Jun 02, 2004 12:25 am
Location: Kalamazoo, Michigan
Contact:

Postby rileydog » Sat Aug 04, 2007 12:29 pm

Where is the new version? It isn't in software update and I just reinstalled the plugin loging into my user account - after I reinstalled it wiped out my license and now it is expired - I am trying to submit an activation request but the activation server times out... The version that was re-installed was the same as before (126).

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Sat Aug 04, 2007 12:59 pm

The new version is in your Registered User's download account.

The license should not have been wiped out by upgrading the plugin.
Ya did something else to wipe out the license key ;)

But, if you did somehow, your old license and Activation will work on the same PC.

chrismd77
Intermediate
Intermediate
Posts: 308
Joined: Wed May 31, 2006 3:04 pm
Location: Shrewsbury, PA
Contact:

Postby chrismd77 » Tue Aug 21, 2007 4:44 pm

I have the exact same proplem as RileyDog. I have downloaded the latest version of the plugin but I still have the same problems. Those being;

When I quit ML Server, I get errors from iPort:

Run-time error -2147418105 (80010007): Automation error - The callee (server [not server application]) is not available (of note I get this same error now too for the MLHS Plugin - I have 2 error messages when I quit ML Server). I don't have any plugin windows open when I quit.

Second is that when I restart ML Server, it seems I have to go to the plugin interface to start making the ML scene work - I go to the plugin on ML Server, click on disconnect then connect - then, everything works.

Does anyone have a fix for this problem yet? Thanks, Chris

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Tue Aug 21, 2007 6:14 pm

The first problem has been around that the developer hasn't addressed yet. The second, will let him know.
Thanx


Return to “iPod”

Who is online

Users browsing this forum: No registered users and 1 guest