Errors displaying some images

Post your HTML code (as attachments) here and a description of what that scene does.
User avatar
albright_family
Intermediate
Intermediate
Posts: 456
Joined: Sat Oct 22, 2005 9:41 pm
Location: Lakewood, WA
Contact:

Errors displaying some images

Postby albright_family » Mon Apr 16, 2007 1:45 pm

I am having a bit of trouble consistently getting certain images to show up. The images in question, are those programmed into MLServer variables (eg. http://HTPC:6246/images/MLWeather/map1.jpg). I have devised a script that will strip away the 'http://HTPC:6246/'. leaving me with just 'images/MLWeather/map1.jpg'. But on every third refresh, the images will not show up, then when I hit refresh again, I get 'Max Web Sessions reached' error message. Here is my code to strip away that portion of code:
(this part goes in the header)
<script type="text/javascript">
function movepic(img_name,img_src) {
document[img_name].src=img_src;
}

function updatePics() {
var callerIDPicvar = '{{mlcallerid_image}}'
var callerIDPiclength = callerIDPicvar.length
movepic('callerIDPic',callerIDPicvar.substring(17,callerIDPiclength))

var currentSurfacePicvar = '{{mlweather_map_1_url}}'
var currentSurfacePiclength = currentSurfacePicvar.length
movepic('currentSurfacePic',currentSurfacePicvar.substring(17,currentSurfacePiclength))
}
</script>.

(in the body tag)
<body onLoad="updatePics();">

(in the body of the page, in each image tag)
<img name="currentSurfacePic" border="0" src="#" width="360" height="243">
....
<img border="0" name="callerIDPic" src="#" width="85" height="115">

Any ideas as to what is going on, or what is causing my script to not pull the correct image (BTW, all of the MLServer images have been copied into the HTML\images folder.)

Dave, maybe this might be up your alley of expertise.

Thanks in advance

Russell

User avatar
albright_family
Intermediate
Intermediate
Posts: 456
Joined: Sat Oct 22, 2005 9:41 pm
Location: Lakewood, WA
Contact:

Postby albright_family » Mon Apr 16, 2007 1:48 pm

Oh by the way, when the images are not showing, I checked their properties, and they are pulling the correct properties. (eg. http://192.168.2.9/Images/CallerID/NotAvailable.jpg, which is a valid file).

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Postby CinemarDave » Thu Apr 19, 2007 12:37 am

In MLServer do a View/Sessions and watch the individual web sessions as you do you refreshes. Do you see sessions stacking up? Are you running out of sessions (5 by default) when your images stop refreshing?

User avatar
albright_family
Intermediate
Intermediate
Posts: 456
Joined: Sat Oct 22, 2005 9:41 pm
Location: Lakewood, WA
Contact:

Postby albright_family » Thu Apr 19, 2007 1:40 am

CinemarDave wrote:In MLServer do a View/Sessions and watch the individual web sessions as you do you refreshes. Do you see sessions stacking up? Are you running out of sessions (5 by default) when your images stop refreshing?


Dave:
In response to this, since I moved all of my web based control software off of my remote website and put it on my local machine. With links pointing to the local machine to launch those set of pages, I haven't experienced this Max Sessions error any more. I have made some tweaks to the page afterwards, and now I cannot get it to recreate the error while I am viewing the Sessions log (BTW, I did not know there was such a log. Boy do I feel dumb.)


Return to “MLServer HTML Sharing”

Who is online

Users browsing this forum: No registered users and 1 guest