Devices Gone (blank), Won't Import... says already used

A plugin that allows for end user development of multiple RS232 device control systems.
tpate
Member
Member
Posts: 93
Joined: Fri Sep 30, 2005 9:11 pm
Location: Ann Arbor, MI
Contact:

Devices Gone (blank), Won't Import... says already used

Postby tpate » Sat Mar 15, 2008 8:22 am

1. How can I get my device to reappear?
2. Need access to .mdb from Access.

This is a very well done plugin! I have used it to develop great 2-way comm with the Panamax 1500 UPS (will post when testing done).

I have 17 days left on the beta version 439, (haven't yet purchased).
Now, on my developement PC, the "Settings" screen shows no devices (list for controlled devices is blank), and shows both 1 basic and 1 advanced devices configured. When I try to import the zip file for the Panamax (which I exported), it says have exceeded limit.

Problem I suspect, is that I moved the GenericDevice.mdb between MLS PCs... one for test, on in production. Replace the development PC .mdb with the production PC .mdb to make additional changes. I do this all the time with Command.mdb, etc.... a necessary capability for a development/production environment.

Another issue I have is that the .mdb is password protected so I can't open it with ACCESS. I use Access tables to document the various .mdb functionality for commands, state tables, etc. I want to be able to document the GenericDevice logic and I assume the access tables would provide tolerable documentation (as they do for the other .mdbs... not ideal but tolerable). How else can I capture MLGD documentation?
Tom

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Sat Mar 15, 2008 8:38 pm

Try upgrading to the lastest version. I think that will take care of the missing device file issue

ccharmatz
Intermediate
Intermediate
Posts: 344
Joined: Wed Oct 15, 2003 12:51 pm
Location: Clearwater Florida
Contact:

Postby ccharmatz » Mon Mar 17, 2008 5:56 am

I believe I am experiencing the same issue. Mlinstaller showed new version available I tried to upgrade and now the device files do not show in the plugin, but they appear to still be the same in the .mdb. Also the first event is " ERROR: The BETA has expired." The eval still has 20 says left on my system.

Have tried re-installing, however even though mlinstaller shows 3.0.461.0 the version 3.0.439.0 is being installed.

I was about to purchase as I have multiple Sharp LC-52D64U's, and the plugin was working flawlessly with the one I had configured.

Please help.

ccharmatz
Intermediate
Intermediate
Posts: 344
Joined: Wed Oct 15, 2003 12:51 pm
Location: Clearwater Florida
Contact:

Postby ccharmatz » Tue Mar 18, 2008 5:40 pm

Ok,

I was able to download the new version instead of installing from the mainlobby installer. This correctly loaded the new version which is now working properly.

Note. the install option from the installer tries to load the older version.

cc-

tpate
Member
Member
Posts: 93
Joined: Fri Sep 30, 2005 9:11 pm
Location: Ann Arbor, MI
Contact:

Postby tpate » Fri Mar 21, 2008 4:29 pm

I also was able to redownload MLGenericDevice and it installed OK (after clicking OK for it to overwrite existing file).

I presume (hope) that the new downloads will resolve the problem of the plugin losing the devices and being unable to reimport them.
Tom


Return to “MLGenericDevice”

Who is online

Users browsing this forum: No registered users and 1 guest