Latest version Blowing up

A plugin that allows for end user development of multiple RS232 device control systems.
User avatar
gstone
Expert
Expert
Posts: 582
Joined: Fri Apr 23, 2004 9:42 am
Contact:

Latest version Blowing up

Postby gstone » Thu Feb 07, 2008 12:47 pm

I have the latest version installed. When I run a command that worked in the previos version in this case the Help command for my device. The device will return data. As soon as the data is returned I get this In my ML logs and then MLServer just closes.

2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain
2/7/2008 11:42:57 AM MLGenericDevice Error Server Error -2147467259(Cannot open any more tables.) @ Line 40 in procedure RS232_OnComm of frmMain

Any ideas?
Always ask! You can't stay dumb forever!

User avatar
gstone
Expert
Expert
Posts: 582
Joined: Fri Apr 23, 2004 9:42 am
Contact:

Postby gstone » Thu Feb 07, 2008 1:42 pm

Attached is the actuall log file.
You do not have the required permissions to view the files attached to this post.
Always ask! You can't stay dumb forever!

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Thu Feb 07, 2008 3:26 pm

gstone:
Can you tell me what version you are on and what command/device you are trying?

Thanks
Tracy

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Thu Feb 07, 2008 3:59 pm

Never mind, I think I see the problem. Should be a new version coming out shortly.

Tracy

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Thu Feb 07, 2008 4:03 pm

Update Posted via MLInstaller

User avatar
gstone
Expert
Expert
Posts: 582
Joined: Fri Apr 23, 2004 9:42 am
Contact:

Postby gstone » Fri Feb 08, 2008 9:11 am

Thanks Smooth I'll give it a try
Always ask! You can't stay dumb forever!

User avatar
gstone
Expert
Expert
Posts: 582
Joined: Fri Apr 23, 2004 9:42 am
Contact:

Postby gstone » Fri Feb 08, 2008 9:27 am

Same problem. I am using a driver I have built to control Autonomic Home Server for the MCE. It has always worked fine until the latest two versions. I am also on the latest version of MLServer. I will attach the log and the driver for you.
You do not have the required permissions to view the files attached to this post.
Always ask! You can't stay dumb forever!

User avatar
gstone
Expert
Expert
Posts: 582
Joined: Fri Apr 23, 2004 9:42 am
Contact:

Postby gstone » Fri Feb 08, 2008 10:55 am

In looking at it more it may actually be a problem with the buffer.

In an older version when the server would return something to MLGenericDevice, the events window would just show it comming in. Now the buffer is very slow.

For instance..issueing the command BrowseInstances would return this:
BeginInstance
MCEServer
Theatre
Bedroom
EndInstance

Now the buffer looks like this when returned:
buffer-->B
buffer-->Be
buffer-->Beg
and so on.

It seems that when a command only returns something small everything works fine. But when there is a large list returned the buffer can't hadle it and everything blows up.

Hope this helps.
Always ask! You can't stay dumb forever!

User avatar
gstone
Expert
Expert
Posts: 582
Joined: Fri Apr 23, 2004 9:42 am
Contact:

Postby gstone » Fri Feb 08, 2008 11:47 am

Well now I have a change. I got rid of the serial cable and used a serial to ethernet converter from Eltima. It is software and works good.

So know nothing blows up, but I have a new issue. When I ask for the DVR titles it returns to MLGenericDevice that there are 67 titles and begins listing them. Unfortunatley it only gets about half of the 67 then nothing more comes across.

A little strange as when I use just a regular telnet to the device it will list all 67. My guess is that MLGereric Device can't hold that much info. Not sure.

Any suggestions.
Always ask! You can't stay dumb forever!

User avatar
gstone
Expert
Expert
Posts: 582
Joined: Fri Apr 23, 2004 9:42 am
Contact:

Postby gstone » Fri Feb 08, 2008 12:03 pm

At this point it definatly appears that the MLGenericDevice can only hold so much info of the returned message.

I have turned the baudrates way down so as not to get any overrun and it will still only read in so much data.

Is there any way to open this up?
Always ask! You can't stay dumb forever!

User avatar
kevind
Intermediate
Intermediate
Posts: 475
Joined: Tue Jan 11, 2005 8:51 pm
Location: Vancouver, BC, Canada
Contact:

Postby kevind » Wed Feb 20, 2008 12:30 am

I'm getting similar errors as you are in your first post. Did the latest version solve this for you? Mine is simply for controlling a pioneer Elite plasma.

90CE
Developer
Developer
Posts: 573
Joined: Mon Nov 28, 2005 1:19 am
Location: Waukee, Iowa
Contact:

Postby 90CE » Wed Feb 20, 2008 12:50 am

The lastest version fix this issue.


Return to “MLGenericDevice”

Who is online

Users browsing this forum: No registered users and 1 guest