Newbie RS232 to EIB with ASCII

A plugin that allows for end user development of multiple RS232 device control systems.
tmax
Member
Member
Posts: 91
Joined: Fri Jun 24, 2005 4:36 pm
Contact:

Newbie RS232 to EIB with ASCII

Postby tmax » Sun Jan 20, 2008 4:27 pm

I am trying to get two way interface to my EIB (European Installation Bus)Home Automation System and I have just purchased a EIB RS232 Interface which supports ASCII

I was going to connect this to my GC10012 and ML via RS232.

What is the best way to get my commands to this interface? What is the best MLserver Plugin to interface with?

ASCII-Protocol description for the RS232 device:
The communication between host and EIB-Mediatechnic-Gateway uses readable text only. The EIB-Mediatechnic-Gateway neither sends nor accepts characters below 20Hex (ASCII Blank). The only exception to this rule is the carriage return char(0d Hexadecimal), shortened called “cr” in the follow-ing text.. The cr is used to signal the end of a transmission. Characters sent from the host are not echoed by the device. All command related characters are treated as uppercase, the means the device is “case insensi-tive”.

The manual says for example to switch a group adress within the EIB I must send a command like
W1/0/1=1 sends a „ON“ telegram on the group address 1/0/1

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Sun Jan 20, 2008 4:49 pm

The best ASCII support plugin is the MLGenericDevice.

tmax
Member
Member
Posts: 91
Joined: Fri Jun 24, 2005 4:36 pm
Contact:

Postby tmax » Wed Feb 20, 2008 4:50 pm

Got the MLGenericDevice, connected to the GC100 with ip static at 192.168.11.10, access through IE is fine, but I cannot get the MLGD to connect to the GC100

when i click on the binoculars set at module 1, it says no ports found for this ip address?

also in the events it says error 40020 port not available - connection state 6??

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Wed Feb 20, 2008 5:44 pm

that I believe is a com port communications issue. You might want to double check that you have ports assigned correctly, and that nothing else is connected to that port (other software).

tmax
Member
Member
Posts: 91
Joined: Fri Jun 24, 2005 4:36 pm
Contact:

Postby tmax » Thu Feb 21, 2008 5:48 pm

I am connecting to the GC100 12 via the lan, and only port 1 one of the GC100 to connect to the EIB Interface.

rechanged the GC100 address but still when i click the binoculars, it says no ports found for this ip address
and still in the log,


error 40020 (invalid operation at current state) @ line 70 in procdure Find GC modules of modsharedcode port not available - connection state 6

also
socket error #10053: connection is aborted due to timeout or other failure (C:windows\system32\mswinsck.oxc)

is this a registery problem??

tmax
Member
Member
Posts: 91
Joined: Fri Jun 24, 2005 4:36 pm
Contact:

Postby tmax » Fri Feb 22, 2008 3:36 pm

I have now connected directly to the EIB interface from my COM 1 port on the PC and it works perfect, so the problem is that ML Server does not seem to connect through the network to the GC100.

Does anybody know why this is the case?

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Sat Feb 23, 2008 7:29 am

firewall issue? We are using MLGenericDevice via GC100 with no issue.
I updated the wiki with the ports involved
http://www.cinemaronlineforums.com/wiki ... ice_Plugin

I assume you did a full install of MLGenericDevice (ran the installer) and didn't just copy over the .dll to the plugins directory. There are dependency files that are required for it to work that have to be installed correctly.


Return to “MLGenericDevice”

Who is online

Users browsing this forum: No registered users and 1 guest