ScreenSaver_On Problem

Application to monitor and control PCs on the LAN
rahl
Member
Member
Posts: 67
Joined: Sat Jun 26, 2004 1:37 am
Location: Melbourne, Australia
Contact:

ScreenSaver_On Problem

Postby rahl » Fri Mar 16, 2007 9:40 pm

I am unsuccessfully trying to activate the screensaver from a client using the following:

Code: Select all

MLServeCmd.MLWMIServer|ScreenSaver_On~BYName~{{clientname}}

I have also unsuccessfully tried using the computer name instead of the {{clientname}} variable and BYIP address .
i.e.

Code: Select all

MLServeCmd.MLWMIServer|ScreenSaver_On~BYName~rahl

Code: Select all

MLServeCmd.MLWMIServer|ScreenSaver_On~BYIP~192.168.10.20

I have successfully tried

Code: Select all

MLServeCmd.MLWMIServer|Monitor_Off~BYIP~192.168.10.20
but cannot get

Code: Select all

MLServeCmd.MLWMIServer|Monitor_Off~BYName~rahl
to work.

I want to use ScreenSaver_On rather than Monitor_Off because I plan to use a photo slideshow as a screensaver.

Any ideas?

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Fri Mar 16, 2007 9:51 pm

sounds like you have a name resolution problem on your LAN. You might try to mod the hosts file if you are PC savvy. Make sure you are talking about PC name, and not necessarily MainLobby client name. Ideally, both are the same name.

rahl
Member
Member
Posts: 67
Joined: Sat Jun 26, 2004 1:37 am
Location: Melbourne, Australia
Contact:

Postby rahl » Fri Mar 16, 2007 10:08 pm

That will probably help with the BYName commands but ScreenSaver_On doesn't work even when using BYIP.

Edit: The computer name and ML client name are the same.

rahl
Member
Member
Posts: 67
Joined: Sat Jun 26, 2004 1:37 am
Location: Melbourne, Australia
Contact:

Postby rahl » Mon Mar 19, 2007 7:50 pm

I fixed the name resolution problem by adding an entry to the hosts file as you suggested.

I solved the screensaver issue too. The *.scr file association had been altered by another program. Once I restored it to the default association, the MLWMI plugin was able to launch the screensaver.

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Mon Mar 19, 2007 8:20 pm

good news, thanx for the tidbits. That should help others.


Return to “MLWMI”

Who is online

Users browsing this forum: No registered users and 1 guest