Sleep_Client is not working...

Application to monitor and control PCs on the LAN
User avatar
mjunky
Senior Member
Senior Member
Posts: 144
Joined: Sat Jul 19, 2003 3:24 pm
Contact:

Sleep_Client is not working...

Postby mjunky » Wed Dec 20, 2006 11:56 pm

I have been trying unsuccessfully to get the sleep function of the WMI server/client apps to work. I can issue the sleep command:

MLServeCMD.MLWMIServer|SLEEP_CLIENT~BYNAME~HTPC1
MLServeCMD.MLWMIServer|SLEEP_CLIENT~BYIP~192.168.1.10

The client goes to sleep but within a few seconds "wakes" back up on its own. This appears to be a function of the MLWMIServer plugin since if I turn the plugin off (unload) then this behavior ceases (the client stays asleep). Also, I believe the WOL settings of the client are correct since stand alone WOL/Sleep apps work as expected as long as the WMI plugin is not loaded.

Attached are the log entries captured during a few such events (nothing very telling)

Nothing shows up in the client log?

One additional piece. The client is set to go to sleep on pressing the power button. Doing so results in the same "brief nap" behavior as when I try to put the client to sleep via the WMI commands.

Any Suggestions?

Thanks
Barry

Code: Select all

Listening to port: 1007
Connection request id 2964 from 127.0.0.1
Received: Data from 127.0.0.1(2964) - 12/20/2006 11:43:11 PM
Connection request id 2764 from 192.168.1.14
Received: Data from 192.168.1.14(2764) - 12/20/2006 11:43:47 PM
CMD: SLEEP_CLIENT~BYNAME~HTPC1 FROM: latitude
Issued GUI WOL command to IPAddress - 192.168.1.10
Sending WOL Command
Connection request id 2768 from 192.168.1.11
Received: Data from 192.168.1.11(2768) - 12/20/2006 11:45:06 PM
Received: Data from 192.168.1.14(2768) - 12/20/2006 11:45:13 PM
Received: Data from 192.168.1.14(2768) - 12/20/2006 11:45:14 PM
Connection request id 2624 from 192.168.1.10
Received: Data from 192.168.1.10(2624) - 12/20/2006 11:46:23 PM
CMD: SLEEP_CLIENT~BYNAME~HTPC1 FROM: latitude
Requesting 192.168.1.10 to sleep
Received: Data from 192.168.1.10(2624) - 12/20/2006 11:47:57 PM
Issued GUI WOL command to IPAddress - 192.168.1.10
Sending WOL Command
CMD: SLEEP_CLIENT~BYNAME~HTPC1 FROM: latitude
Requesting 192.168.1.10 to sleep
Connection request id 376 from 192.168.1.12
Received: Data from 192.168.1.12(376) - 12/20/2006 11:49:45 PM
Received: Data from 192.168.1.11(376) - 12/20/2006 11:50:10 PM
Received: Data from 192.168.1.11(376) - 12/20/2006 11:50:11 PM
CMD: SLEEP_CLIENT~BYNAME~HTPC1 FROM: latitude
Requesting 192.168.1.10 to sleep
Received: Data from 192.168.1.14(376) - 12/20/2006 11:53:48 PM
Received: Data from 192.168.1.11(376) - 12/20/2006 11:55:07 PM
Received: Data from 192.168.1.14(376) - 12/20/2006 11:55:16 PM
Received: Data from 192.168.1.14(376) - 12/20/2006 11:55:17 PM

User avatar
DavidL
Simply Incredible
Simply Incredible
Posts: 11071
Joined: Sat Feb 08, 2003 9:39 am
Location: Metamora, Michigan
Contact:

Postby DavidL » Thu Dec 21, 2006 12:15 am

I wonder if the data update from WMIClient to server is waking things up
I tried it and it put it to sleep fine. Haven't tried leaving it alone yet.

User avatar
mjunky
Senior Member
Senior Member
Posts: 144
Joined: Sat Jul 19, 2003 3:24 pm
Contact:

Postby mjunky » Thu Dec 21, 2006 7:25 am

I should mention this is happening with MULTIPLE clients. Very different h/w setups but same behavior.

I was wondering if there was some update function that was causing this to happen. I am using the default settings (see screen shot) and the updates are well outside of the time interval the client stays asleep. I thought this may have been due to the "reconnect interval" that I believe was introduced in the last version. I increased the interval to 10 minutes with no change?!

Ideas?

Barry
You do not have the required permissions to view the files attached to this post.

User avatar
Krumpy
Developer
Developer
Posts: 1228
Joined: Thu Sep 04, 2003 10:17 pm
Location: Minneapolis, Mn
Contact:

Postby Krumpy » Fri Dec 22, 2006 4:26 am

Make sure that you have your clients set to use the magic packet only. Otherwise, any packet destined to that client will wake it back up.

More than likely this is a networking situation rather than plugin issue.

User avatar
Krumpy
Developer
Developer
Posts: 1228
Joined: Thu Sep 04, 2003 10:17 pm
Location: Minneapolis, Mn
Contact:

Postby Krumpy » Sat Jan 06, 2007 11:02 am

What did you find out? Did you get this resolved?

User avatar
davevans
Intermediate
Intermediate
Posts: 455
Joined: Mon Aug 04, 2003 2:36 am
Location: Tampa, FL
Contact:

Postby davevans » Tue Jan 13, 2009 10:55 pm

I am having this exact problem with multiple clients. How do you set it to respond to the magic packet only as you suggest?

kirkfrey
Expert
Expert
Posts: 759
Joined: Wed Jan 12, 2005 10:55 am
Contact:

Re: Sleep_Client is not working...

Postby kirkfrey » Mon Sep 21, 2009 8:54 pm

I am having the same issue, was this ever resolved? My client is W7, not sure if that makes a difference.
Kirk

Just trying to figure it out...


Return to “MLWMI”

Who is online

Users browsing this forum: No registered users and 1 guest