MLHAI ms.jet.oledb.4.0 missing error message

Plugin for the HAI family of security panels
AndyM
Newbie
Newbie
Posts: 6
Joined: Wed Apr 08, 2009 7:38 pm
Location: United States
Contact:

MLHAI ms.jet.oledb.4.0 missing error message

Postby AndyM » Tue Sep 22, 2009 11:26 am

Hello;

While trying to install MLHAI Agent on a Windows Vista 64 bit OS I am getting an error:

"The microsoft.jet.oledb.4.0 provider is not registered on the local machine".

All the generic internet posts I find refer to recompiling code due to older MS Access DB's not being 64 bit (files, registry and DLL settings differ)?
However, the other "database" MLplugins appear to work fine.

Any help would be greatly appreciated.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLHAI ms.jet.oledb.4.0 missing error message

Postby CinemarDave » Tue Sep 22, 2009 12:06 pm

The MLHAI agent was compiled targeting a 32bit OS. That's why you are seeing the error. I just recompiled the Agent targeting any OS. Give version 3.0.3462.30364 a try. I do not run 64 bit OS's so I cannot test it.

AndyM
Newbie
Newbie
Posts: 6
Joined: Wed Apr 08, 2009 7:38 pm
Location: United States
Contact:

Re: MLHAI ms.jet.oledb.4.0 missing error message

Postby AndyM » Tue Sep 22, 2009 12:45 pm

Thank you for your response.

When I downloaded from updater it downloaded version 3.0.3462.30365

Still have same error message

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLHAI ms.jet.oledb.4.0 missing error message

Postby CinemarDave » Tue Sep 22, 2009 1:00 pm

It's probably one of the 3rd party controls or the MAI NetLib dll that isn't compatible then. I'll have to test further.

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLHAI ms.jet.oledb.4.0 missing error message

Postby CinemarDave » Thu Oct 08, 2009 7:58 pm

The Agent has been recompiled and will now run on 64bit OS's. Look for version 3.0.3566.31331 of the HAI Agent.


Return to “MLHAI”

Who is online

Users browsing this forum: No registered users and 1 guest