MLCallerID - event log correct, call log drops chars

MLNetCallerID supports the NetCallerID hardware and sends CallerID data to MLCallerID plugin. MLCallerID3 uses a database to store your call data. MLPhoneBook is a MainLobby view to your Outlook contacts list. MLPhoneDialer allows for dialing of a phone number for you.
jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

MLCallerID - event log correct, call log drops chars

Postby jwr » Mon Dec 08, 2008 10:04 am

I finally got a modem that will report caller ID reliably and it appears that the MLCallerID plugin is dropping the first 2 characters of the name and the number when it creates the call log entry. The number is indicated as Not Available on the first call after the MLServer starts. The caller information is correct in the plugin event log, but incorrect in the call log. Screen shots attached.
You do not have the required permissions to view the files attached to this post.

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Update?

Postby jwr » Thu Feb 19, 2009 5:56 pm

Is there any update on this post? Version 3.0.233 (01/16/2009) of the MLCallerID plugin addressed the characters that were being dropped but the number associated with a callers name is still not correct. The event log shows the fields came from the modem correctly, but the call log associates the most recent callers name with the number from the prior call.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Thu Feb 19, 2009 9:59 pm

Look at the masking settings. The plugin works. I am sure this is the issue. The settings are under the Comds/Vars Tab of the setup screen for the plugin. Make sure you are running 3.0.233 or better.
Thanks!

Dave Bruner
:shock:

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Postby jwr » Fri Feb 20, 2009 11:02 am

Dave,

Thanks for the response but I don't understand what you mean by masking settings. I've attached a screen shot of the Cmd/Vars tab in the plugin.
You do not have the required permissions to view the files attached to this post.

User avatar
DaveB
Simply Incredible
Simply Incredible
Posts: 3143
Joined: Sun May 30, 2004 10:57 pm
Location: Mays Landing, NJ
Contact:

Postby DaveB » Fri Feb 20, 2009 9:21 pm

The mask is wrong. Try this;

@-@@@-@@@-@@@@

Your's is set to this;

@@@-@@@-@@@@


Missing the "1" at the beginning of the string can screw up the result.

(IE: Mask = Variable Format Options / Number at the bottom of the setup screen. )
Thanks!

Dave Bruner
:shock:

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Postby jwr » Sun Mar 15, 2009 1:54 pm

Thanks Dave.

I tried all kinds of combinations on the mask and nothing changed the incorrect behavior. When I set the mask to @-@@@-@@@-@@@@ it just changed the formatting of the number in the server variables.

The callers name and phone number association is still one off.

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Postby jwr » Sun Mar 15, 2009 3:43 pm

It appears this plugin has had this problem for quite some time... This post captures the same problem with different modems.

http://www.cinemaronlineforums.com/forum/viewtopic.php?t=10751

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Postby jwr » Wed Jun 03, 2009 3:12 pm

Just bumping the posting here. It's approaching 7 months now and this problem is still there. If someone could post with a USB modem that works correctly with the existing plugin, I will purchase it. I'm getting tired of looking at the main screen for my home automation system and seeing caller names and numbers with the first two letters missing.

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Re: MLCallerID - event log correct, call log drops chars

Postby jwr » Tue Dec 15, 2009 12:35 pm

Well I just crossed the 1 year anniversery of this bug in my system. Every day I get to pass by the main screens of my automation system and see the last caller name associated with an incorrect phone number (the phone number is from the previous caller). The other night I hosted a Christmas party and one of my guests pointed out the phone number of the person who just called for directions with incorrect. They weren't impressed. It would be very nice if this problem could be addressed and fixed, until then I'll re-post my request for someone to reply with the name/model of a USB modem that works correctly with the current caller ID plugin.

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Re: MLCallerID - event log correct, call log drops chars

Postby jwr » Thu Jun 24, 2010 3:24 pm

I just purchased my third modem for use with MLCallerID and it has the exact same results as the others. In the plugin call log the initial caller's name shows up correctly and has a Not Available phone number. The second caller's name shows up correctly, but has the phone number of the prior caller. This continues and the entire log has name and number associated incorrectly. The plugin event log entries displayed from communication with the modem are correct. The translation of this data to the plugin call log is not working corretly. I first posted this problem in December 2008. Is anyone ever going to fix this software bug?

User avatar
CinemarDave
Site Admin
Site Admin
Posts: 10535
Joined: Fri Feb 07, 2003 8:56 am
Location: Planet Earth
Contact:

Re: MLCallerID - event log correct, call log drops chars

Postby CinemarDave » Thu Jun 24, 2010 7:47 pm

Version 239 of the Caller ID plugin was released today. It should resolve these problems. Also I would suggest changing the mask to !(@@@) @@@-@@@@

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Re: MLCallerID - event log correct, call log drops chars

Postby jwr » Fri Jun 25, 2010 9:29 am

Thanks Dave!! This fixed my problem.

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Re: MLCallerID - event log correct, call log drops chars

Postby jwr » Tue Jun 07, 2011 10:49 am

Hi Dave,

I recently upgraded to Windows 7 and pulled the latest MLCallerID plugin (version 3.99.2.0 dated 02/10/2011) and this problem is back. Was the code change lost?

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Re: MLCallerID - event log correct, call log drops chars

Postby jwr » Mon Jul 18, 2011 9:20 am

Upgraded to version 3.99.5 and the code to allow the caller ID NAME to appear before NMBR is still lost. Can we get a version that contains this code change?

jwr
Senior Member
Senior Member
Posts: 134
Joined: Sat Oct 25, 2008 11:13 am
Contact:

Re: MLCallerID - event log correct, call log drops chars

Postby jwr » Thu Nov 03, 2011 2:04 pm

Never saw a reply to this... MLCallerID v3.99.5 is reporting incorrect phone numbers.

If I receive the following in the Comm Settings Event Log:

RING
DATE = 1103
TIME = 1444
NAME = CALLER1
NMBR = 7037752113
RING
RING
DATE = 1103
TIME = 1445
NAME = CALLER2
NMBR = 7032145609
RING
RING
DATE = 1103
TIME = 1446
NAME = CALLER3
NMBR = 7039803204
RING

I get this in the Call Log within the plugin:

11/3/2011 2:46:59 PM CALLER3 (703) 214-5609
11/3/2011 2:45:37 PM CALLER2 NOT AVAILABLE
11/3/2011 2:44:54 PM CALLER1 (703) 775-2113

The number listed for CALLER3 is actually from CALLER2. From this point on the numbers are one off.


Return to “Phone Support”

Who is online

Users browsing this forum: No registered users and 1 guest